ports/www/angie/Makefile

86 lines
3.0 KiB
Makefile

#ONLY_FOR_ARCHS = ???
#NOT_FOR_ARCHS = ???
COMMENT = A web server as drop-in replacement for Nginx
VERSION = 1.1.0
DISTNAME = angie-${VERSION}
#PKGNAME = ???
CATEGORIES = www
HOMEPAGE = https://angie.software
MAINTAINER = vasyahacker <vasya@magicfreedom.com>
# BSD-like
PERMIT_PACKAGE= Yes
WANTLIB = c z pcre ssl crypto exslt xml2 xslt gd m perl
#exslt xml2 xslt
LIB_DEPENDS = devel/pcre \
graphics/gd \
textproc/libxml \
textproc/libxslt
MODULES += perl
MASTER_SITES = https://download.angie.software/files/
#MASTER_SITES0 = https://github.com/
EXTRACT_SUFX = .tar.gz
#DIST_SUBDIR = ???
#PATCHFILES = ???
#PATCH_DIST_STRIP = -p0
COMPILER = base-clang ports-gcc base-gcc
.include <bsd.port.arch.mk>
NO_TEST = Yes
CONFIGURE_STYLE= simple
CFLAGS = -Wall
ALL_TARGET=
ANGIE_DIR = /var/www
SUBST_VARS = ANGIE_DIR
CONFIGURE_ARGS = --prefix=${ANGIE_DIR} \
--conf-path=${SYSCONFDIR}/angie/angie.conf \
--sbin-path=${PREFIX}/sbin/angie \
--pid-path=/var/run/angie.pid \
--lock-path=/var/run/angie.lock \
--http-log-path=logs/access.log \
--error-log-path=logs/error.log \
--http-client-body-temp-path=${ANGIE_DIR}/cache/client_body_temp \
--http-proxy-temp-path=${ANGIE_DIR}/cache/proxy_temp \
--http-fastcgi-temp-path=${ANGIE_DIR}/cache/fastcgi_temp \
--http-scgi-temp-path=${ANGIE_DIR}/cache/scgi_temp \
--http-uwsgi-temp-path=${ANGIE_DIR}/cache/uwsgi_temp \
--user=www \
--group=www \
--with-http_auth_request_module \
--with-http_dav_module \
--with-http_image_filter_module=dynamic \
--with-http_gzip_static_module \
--with-http_gunzip_module \
--with-http_perl_module=dynamic \
--with-http_realip_module \
--with-http_slice_module \
--with-http_ssl_module \
--with-http_stub_status_module \
--with-http_v2_module \
--with-http_xslt_module=dynamic \
--with-mail=dynamic \
--with-stream=dynamic \
--with-stream_ssl_module \
--with-stream_ssl_preread_module \
--without-pcre2
SUBSTFILES= conf/angie.conf
pre-configure:
@cd ${WRKSRC} && ${SUBST_CMD} ${SUBSTFILES}
do-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/angie/
${INSTALL_PROGRAM} ${WRKSRC}/objs/angie ${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/objs/angie.8 ${PREFIX}/man/man8/
${INSTALL_DATA} ${WRKSRC}/conf/* ${PREFIX}/share/angie/
${INSTALL_DATA_DIR} ${PREFIX}/share/angie/html/
${INSTALL_DATA} ${WRKSRC}/html/* ${PREFIX}/share/angie/html/
${INSTALL_DATA_DIR} ${WRKINST}/var/www/modules/
${INSTALL_DATA} ${WRKSRC}/objs/*.so ${WRKINST}/var/www/modules/
${INSTALL_DATA_DIR} ${PREFIX}/${P5ARCH}/auto/nginx/
${INSTALL_DATA} ${WRKSRC}/objs/src/http/modules/perl/blib/lib/nginx.pm \
${PREFIX}/${P5ARCH}/
${INSTALL_DATA} ${WRKSRC}/objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.so \
${PREFIX}/${P5ARCH}/auto/nginx/
.include <bsd.port.mk>